Tuesday, March 22, 2011

Solaris Interview Questions

Explain rc script and run level
Rc script : check and mount the file system, start and stop the various process.
Run level: Base on the init phases 8 run level
m
Which file will take place while booting.
# /etc/inittab

How many file to modify the host name to be changed without rebooting the system.
There are 6 files.
#vi /etc/hosts
#vi /etc/nodename
#vi /etc/hostname.hme
#vi /etc/net/ticlts/hosts
#vi /etc/net/ticosts/hosts
#vi /etc/net/ticotsord/hostst

Where the ip address will be stored

# /etc/hosts
# /etc/hosts.equi
# /etc/hosts.hme

How to configure the network card

# ifconfig hme0 plumb
# ifconfig hme0 192.9.200.10 netmask 255.255.255.0 up
# vi /etc/hosts ( update the ip address )
# vi /etc/hosts.hme0 ( update the ip address ) --> to bring the interface along with the ipaddress during boot time.

How to configure the virtual ip address

Infinity virtual ip address can be created.
# ifconfig hme0:1 plumb
# ifconfig hme0:1 192.9.200.10 netmask 255.255.255.0 up
# vi /etc/hosts ( update the ip address )
# vi /etc/hosts.hme0:1 ( update the ip address ) --> to bring the interface along with the ipaddress during boot time.

How to find the network card speed

# ndd –get /dev/hme link_speed            
1 = 100mbps
0 = 10mbps

How to modify network card speed

# ndd –set /dev/hme instance 0
# ndd –get /dev/hme link_status
# ndd –get /dev/hme link_mode
             To modify
# ndd –set /dev/eri instance 0
# ndd –set /dev/eri adv_100T4_cap0
# ndd –set /dev/eri adv_100fdx_cap1
# ndd –set /dev/eri adv_100hdx_cap0
# ndd –set /dev/eri adv_10fdx_cap0
# ndd –set /dev/eri adv_10hdx_cap0
# ndd –set /dev/eri adv_autoneg_cap0